​Dangerous bugs in older Internet Explorer won’t see patches today

There's a remote code execution bug affecting Internet Explorer (IE) 7 through to 11, but only IE 11 will receive a patch today. That means the most important update on Microsoft's first Patch Tuesday of the year will be to get rid of older version of IE.

Microsoft warned over a year ago that on January 12, 2016 it would cut off support for older versions of IE, with only the latest versions of the browser to receive security patches.

As of today IE 11 is now the only browser for Windows 7 SP 1 and Windows 8.1 that will receive patches and that means Windows users who don’t move on to IE 11 will be exposed to known and dangerous bugs, many of which can be remotely exploited. The latest Microsoft browser for Windows Vista SP2 is IE 9.

Microsoft says in its January security bulletin for IE that the most severe of two vulnerabilities — identified as CVE-2016-0002 — “could allow remote code execution if a user views a specially crafted webpage using Internet Explorer.” The scripting engine memory corruption vulnerability affects IE 8 through to 11 on Windows client and Window Server, as well as IE 11 on Windows 10.

Microsoft highlighted recently in a blog explaining security improvements in its Windows 10 Edge browser, a key threat to users are exploit kits, which can infect PCs with malware simply getting them to visit a malicious web page with a vulnerable browser of plugin like Flash Player. As time passes from today’s patches for IE 11, users with older versions of IE installed are more likely to be affected by these attacks. Microsoft’s data showed that six vulnerabilities were exploited last year within 10 days of a patch’s release, and a further four were exploited within 30 days of patch.

For enterprise customers that are running line of business applications that depend on older pre-IE 11 browsers, Microsoft has released Enterprise Mode for IE 11, which offers backward compatibility and supports many legacy web applications.

The company also released fixes for two critical remote code execution bugs affecting Edge on Windows 10.

The Edge flaws however do require some user interaction to be exploited. As Microsoft notes: “An attacker could host a specially crafted website that is designed to exploit the vulnerability through Microsoft Edge, and then convince a user to view the website. The attacker could also take advantage of compromised websites and websites that accept or host user-provided content or advertisements by adding specially crafted content that could exploit the vulnerability. In all cases, however, an attacker would have no way to force users to view the attacker-controlled content. Instead, an attacker would have to convince users to take action, typically by way of enticement in an email or Instant Messenger message, or by getting them to open an attachment sent through email.”

Other bulletins addressing critical remote code execution bugs are available to address bugs affecting VBScript scripting engine in Windows, Office, Windows Kernel-Mode Drivers and Silverlight.

Read more: Industry cold on data-retention grants as analytics steams towards hot 2016

Microsoft said it was not aware of any attacks on the critical vulnerabilities it addressed in patches today, however several of the flaws have been publicly disclosed.


Participate in CSO and Gigamon's survey on Security Priorities today!

Go into the draw for a chance to win an Apple iWatch Sports or the equivalent of $500 Visa Cashcard.

For full terms and conditions click here.

Start survey NOW!

Join the CSO newsletter!

Error: Please check your email address.

Tags bug fixMicrosoftflash playerWindows 7Internet ExplorerCSO AustraliaWindows 8.1Patch Tuesdaypatch

More about AppleCSOGigamonMessengerMicrosoftVisa

Show Comments

Featured Whitepapers

Editor's Recommendations

Solution Centres

Stories by Liam Tung

Latest Videos

More videos

Blog Posts