Corporate Partners

OpenSSL, critical encryption component, gets nine software fixes

None of the problems are as bad as Heartbleed, but administrators are advised to patch

Nine software fixes were released Wednesday for OpenSSL, a critical encryption component for exchanging data on the web, although none of the problems are as severe as the "Heartbleed" issue found in April.

All of the issues were reported during June and July by security analysts with software vendors Google, Codenomicon, LogMeIn and NCC Group, according to an advisory.

The latest patches fixed several problems that can be triggered through denial-of-service attacks, which can cause OpenSSL to crash, consume large amounts of memory or leak information.

OpenSSL's code has been intensively examined since April, when vendor Codenomicon found the so-called "Heartbleed" vulnerability, a server-side memory leak that could divulge passwords and private SSL/TLS (Secure Sockets Layer/Transport Layer Security) keys needed to decode encrypted data traffic. Adding to the risk, an attack using Heartbleed is undetectable.

The Heartbleed flaw acted as wake-up call to more closely vet the code of open-source projects, as OpenSSL is widely used across websites and applications for encryption. Since then, OpenSSL has undertaken a code review and software vendors have committed resources to trying to keep the application bug free.

One of the patches fixes an error that cause an OpenSSL server to downgrade to a lower level of security. The error occurs when a "ClientHello" message that is badly fragmented is sent to a server during a man-in-the-middle attack, the advisory said. OpenSSL will downgrade to TLS 1.0, a very early version of the protocol that dates back 15 years.

Send news tips and comments to jeremy_kirk@idg.com. Follow me on Twitter: @jeremy_kirk

Tags patchesGoogleCodenominconsecuritylogmeinNCC GroupExploits / vulnerabilities

More about GoogleLogMeIn

Comments

Comments are now closed

Market Place